libunwind: update to 1.5.0
authorRosen Penev <rosenp@gmail.com>
Wed, 9 Dec 2020 01:56:59 +0000 (17:56 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 16 Dec 2020 21:11:19 +0000 (22:11 +0100)
Cleanup Makefile for consistency with other ones.

Remove PKG_SSP. It can be fixed with -lssp_nonshared.

Add PKG_BUILD_PARALLEL for faster compilation.

Add zlib dependency. 1.5.0 requires it now.

Refresh patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/libunwind/Makefile
package/libs/libunwind/patches/002-fix-building-getcontext_S.patch
package/libs/libunwind/patches/003-fix-missing-ef_reg-defs-with-musl.patch

index 994ee97a1757613c03db2383288daeff1a34d992..89e6f84ff53b5a38c2c055f13d87a8ea6b89d25a 100644 (file)
@@ -9,22 +9,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libunwind
-PKG_VERSION:=1.3.1
+PKG_VERSION:=1.5.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
-PKG_HASH:=43997a3939b6ccdf2f669b50fdb8a4d3205374728c2923ddc2354c65260214f8
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
+PKG_HASH:=90337653d92d4a13de590781371c604f9031cdb50520366aa1e3a91e1efb1017
 
+PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
 PKG_LICENSE:=X11
 PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:libunwind_project:libunwind
 
-PKG_MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
-PKG_SSP:=0
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libunwind
@@ -32,7 +32,7 @@ define Package/libunwind
   CATEGORY:=Libraries
   TITLE:=The libunwind project
   URL:=http://www.nongnu.org/libunwind/
-  DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386)))
+  DEPENDS:=@((mips||mipsel||x86_64||arm||aarch64)||(USE_GLIBC&&(powerpc||i386))) +zlib
   ABI_VERSION:=8
 endef
 
@@ -43,8 +43,9 @@ endef
 CONFIGURE_ARGS += \
        --disable-documentation \
        --disable-tests \
-       --enable-minidebuginfo=no \
+       --disable-minidebuginfo
 
+TARGET_LDFLAGS += $(if $(CONFIG_USE_MUSL),-lssp_nonshared)
 
 define Package/libunwind/install
        $(INSTALL_DIR) $(1)/usr/lib
index 10b1dd1d9098ac18d1a2dc43ba1ff7d1bc717c1f..d88594e6e7fcb28f230538ddec90bd08bd9af110 100644 (file)
@@ -1,6 +1,5 @@
-diff -uprN a/src/mips/getcontext.S b/src/mips/getcontext.S
---- a/src/mips/getcontext.S    2012-10-06 12:54:38.000000000 +0800
-+++ b/src/mips/getcontext.S    2016-06-08 13:35:25.033051679 +0800
+--- a/src/mips/getcontext.S
++++ b/src/mips/getcontext.S
 @@ -24,12 +24,12 @@ OF CONTRACT, TORT OR OTHERWISE, ARISING
  WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.  */
  
@@ -16,4 +15,3 @@ diff -uprN a/src/mips/getcontext.S b/src/mips/getcontext.S
  #  define OFFSET 4
  # else
  #  define OFFSET 0
-
index 465abb4ce0b8893a8a44d787a2fd03d3401f84cd..1a26dcd8959ad902993ff393b6881cafe0642cd0 100644 (file)
@@ -1,7 +1,6 @@
-diff -uprN a/include/libunwind-mips.h b/include/libunwind-mips.h
---- a/include/libunwind-mips.h 2012-10-06 12:54:38.000000000 +0800
-+++ b/include/libunwind-mips.h 2016-06-08 13:55:55.029436442 +0800
-@@ -111,6 +111,42 @@ typedef enum
+--- a/include/libunwind-mips.h
++++ b/include/libunwind-mips.h
+@@ -114,6 +114,42 @@ typedef enum
    }
  mips_regnum_t;
  
@@ -44,4 +43,3 @@ diff -uprN a/include/libunwind-mips.h b/include/libunwind-mips.h
  typedef enum
    {
      UNW_MIPS_ABI_O32,
-