libuv: bump to 1.45.0
authorHirokazu MORIKAWA <morikw2@gmail.com>
Sat, 17 Jun 2023 00:52:25 +0000 (09:52 +0900)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 18 Jun 2023 06:00:00 +0000 (08:00 +0200)
1.45.0
* linux: introduce io_uring support
* src: add new metrics APIs
* unix,win: give thread pool threads an 8 MB stack
* win,unix: change execution order of timers

1.44.2
* loop: better align order-of-events behavior between platforms
* zos: fix fs event not fired if the watched file is moved/removed/recreated
* win: Fix pipe resource leak if closed during connect (and other bugs)
* zos: don't error when killing a zombie process
* macos: avoid posix_spawnp() cwd bug
* kqueue: skip EVFILT_PROC events when invalidating events for an fd.

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
libs/libuv/Makefile

index 37738c6fd0784ca17228c890a5a6cc1e97ca53db..5b4bface1a5d631a3465ce81d0e423ec5a1d9012 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libuv
-PKG_VERSION:=1.44.1
+PKG_VERSION:=1.45.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dist.libuv.org/dist/v$(PKG_VERSION)/
-PKG_HASH:=9d37b63430fe3b92a9386b949bebd8f0b4784a39a16964c82c9566247a76f64a
+PKG_HASH:=f5b07f65a1e8166e47983a7ed1f42fae0bee08f7458142170c37332fc676a748
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
 
 PKG_MAINTAINER:=Marko Ratkaj <markoratkaj@gmail.com>