kernel: Package GOOGLE_FIRMWARE drivers
authorBrian Norris <computersforpeace@gmail.com>
Sun, 20 Feb 2022 01:26:24 +0000 (17:26 -0800)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 25 Mar 2022 17:14:13 +0000 (18:14 +0100)
Useful for some Chromium OS based systems, like Google WiFi.

Signed-off-by: Brian Norris <computersforpeace@gmail.com>
package/kernel/linux/modules/other.mk

index 5ccc86079049a5a4e9e18df277535015e76511de..d343ff8d282ab0b7b61257d2966991de2fd012f8 100644 (file)
@@ -182,6 +182,32 @@ endef
 $(eval $(call KernelPackage,eeprom-at25))
 
 
+define KernelPackage/google-firmware
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Google firmware drivers (Coreboot, VPD, Memconsole)
+  KCONFIG:= \
+       CONFIG_GOOGLE_FIRMWARE=y \
+       CONFIG_GOOGLE_COREBOOT_TABLE \
+       CONFIG_GOOGLE_MEMCONSOLE \
+       CONFIG_GOOGLE_MEMCONSOLE_COREBOOT \
+       CONFIG_GOOGLE_VPD
+  FILES:= \
+         $(LINUX_DIR)/drivers/firmware/google/coreboot_table.ko \
+         $(LINUX_DIR)/drivers/firmware/google/memconsole.ko \
+         $(LINUX_DIR)/drivers/firmware/google/memconsole-coreboot.ko \
+         $(LINUX_DIR)/drivers/firmware/google/vpd-sysfs.ko
+  AUTOLOAD:=$(call AutoProbe,coreboot_table memconsole-coreboot vpd-sysfs)
+endef
+
+define KernelPackage/google-firmware/description
+  Kernel modules for Google firmware drivers. Useful for examining firmware and
+  boot details on devices using a Google bootloader based on Coreboot. Provides
+  files like /sys/firmware/log and /sys/firmware/vpd.
+endef
+
+$(eval $(call KernelPackage,google-firmware))
+
+
 define KernelPackage/gpio-f7188x
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Fintek F718xx/F818xx GPIO Support