add microcom
authorFelix Fietkau <nbd@openwrt.org>
Tue, 24 May 2005 14:25:55 +0000 (14:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 24 May 2005 14:25:55 +0000 (14:25 +0000)
SVN-Revision: 1050

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/microcom/Config.in [new file with mode: 0644]
openwrt/package/microcom/Makefile [new file with mode: 0644]
openwrt/package/microcom/ipkg/microcom.control [new file with mode: 0644]

index 7e81af5a70fdbd0072db1ab879b1e90615ff97c9..9fe2faf3b4cc6d9ab0e4a06bdedc840e3f07c609 100644 (file)
@@ -109,6 +109,7 @@ source "package/uclibc++/Config.in"
 source "package/zlib/Config.in"
 
 comment "Utilities ---"
+source "package/microcom/Config.in"
 source "package/usbutils/Config.in"  # lsusb
 source "package/setserial/Config.in"
 source "package/strace/Config.in"
index 5dd8432b6c0cacf61b981daba4ce98cd2ef14c7c..8a5cd0619d6190b0d4bc716d95607b410eaad96a 100644 (file)
@@ -50,6 +50,7 @@ package-$(BR2_PACKAGE_LIGHTTPD) += lighttpd
 package-$(BR2_PACKAGE_LZO) += lzo
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
+package-$(BR2_PACKAGE_MICROCOM) += microcom
 package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_PACKAGE_MONIT) += monit
 package-$(BR2_PACKAGE_MYSQL) += mysql
diff --git a/openwrt/package/microcom/Config.in b/openwrt/package/microcom/Config.in
new file mode 100644 (file)
index 0000000..29c4f5b
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_MICROCOM
+       tristate "microcom (serial terminal)"
+       default m
+       help
+         microcom is a minicom-like serial terminal emulator with scripting 
+         support.
diff --git a/openwrt/package/microcom/Makefile b/openwrt/package/microcom/Makefile
new file mode 100644 (file)
index 0000000..b6b2ac1
--- /dev/null
@@ -0,0 +1,43 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=microcom
+PKG_VERSION:=1.02
+PKG_FILEVERSION:=102
+PKG_RELEASE:=1
+PKG_MD5SUM:=c7817035dc41cb02e7cfb565cf9b7401
+
+PKG_SOURCE_URL:=http://microcom.port5.com/
+PKG_SOURCE:=m$(PKG_FILEVERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MICROCOM,microcom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.prepared:
+       rm -rf $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_BUILD_DIR)
+       # the .tar.gz is different - no subdirectory, so do this manually
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS) -
+       touch $@
+
+$(PKG_BUILD_DIR)/.configured:
+       cp $(PKG_BUILD_DIR)/Makefile  $(PKG_BUILD_DIR)/Makefile.tmp
+       sed 's~gcc~$$(CC)~' $(PKG_BUILD_DIR)/Makefile.tmp > $(PKG_BUILD_DIR)/Makefile
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) CC=$(TARGET_CC)
+       touch $@
+
+$(IPKG_MICROCOM):
+       install -d -m0755 $(IDIR_MICROCOM)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/microcom $(IDIR_MICROCOM)/usr/bin
+       $(RSTRIP) $(IDIR_MICROCOM)
+       $(IPKG_BUILD) $(IDIR_MICROCOM) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/microcom/ipkg/microcom.control b/openwrt/package/microcom/ipkg/microcom.control
new file mode 100644 (file)
index 0000000..002abe4
--- /dev/null
@@ -0,0 +1,6 @@
+Package: microcom
+Priority: optional
+Section: console
+Maintainer: Georg Lukas <georg@boerde.de>
+Source: buildroot internal
+Description: serial terminal