sstp-client: bump to 1.0.19
authorKoen Vandeputte <koen.vandeputte@citymesh.com>
Fri, 10 Nov 2023 14:14:20 +0000 (15:14 +0100)
committerRosen Penev <rosenp@gmail.com>
Fri, 10 Nov 2023 17:54:37 +0000 (09:54 -0800)
After 1.0.18, this project moved from SourceForge to gitlab

Also, since 1.0.19, the configure script is not present
by default anymore, so we need to add autoreconf to generate it

Release notes:
https://gitlab.com/sstp-project/sstp-client/-/releases

Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
net/sstp-client/Makefile
net/sstp-client/patches/200-openssl-deprecated.patch

index 7010fba520d4e58fbff8f4447048d0baed71e6ca..8d7ff0738c2375e7a78b02d37e145cf741c686a1 100644 (file)
@@ -8,17 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sstp-client
-PKG_VERSION:=1.0.15
+PKG_VERSION:=1.0.19
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/sstp-client/$(PKG_VERSION)
-PKG_HASH:=8484aa51fbfbe418a0ebad58ad20a8ee1c46ed71f800be18bcd23b42e6baad64
+PKG_SOURCE_URL:=https://gitlab.com/sstp-project/sstp-client/-/archive/1.0.19/
+PKG_HASH:=e2652365f69f5037102e78f4e115ff764a390b27bb3fd513a8a50b10a61bb613
 
 PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
 
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sstp-client
index 3d2eb9462c991076c981266b35e4fc440a3df970..a9d5683eac1e8b2a5c652ddafa05cd3352069277 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/sstp-client.c
 +++ b/src/sstp-client.c
-@@ -542,6 +542,7 @@ static status_t sstp_init_ssl(sstp_clien
+@@ -546,6 +546,7 @@ static status_t sstp_init_ssl(sstp_clien
      int retval = SSTP_FAIL;
      int status = 0;
  
@@ -8,7 +8,7 @@
      /* Initialize the OpenSSL library */
      status = SSL_library_init();
      if (status != 1)
-@@ -555,6 +556,9 @@ static status_t sstp_init_ssl(sstp_clien
+@@ -575,6 +576,9 @@ static status_t sstp_init_ssl(sstp_clien
  
      /* Create a new crypto context */
      client->ssl_ctx = SSL_CTX_new(SSLv23_client_method());