motion: add basic procd init script
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 4 Dec 2018 22:53:00 +0000 (00:53 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Sun, 1 Dec 2019 22:10:04 +0000 (00:10 +0200)
Disable the init script by default to avoid log pollution; motion is
very verbose when it cannot open the configured camera.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
multimedia/motion/Makefile
multimedia/motion/files/motion.conf [new file with mode: 0644]
multimedia/motion/files/motion.init [new file with mode: 0644]

index 037afcd0ca19108b7b0345d31ce83e551ffdeb09..c696d7152317695d4adade6cfb64d0870dd55dbe 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
 PKG_VERSION:=4.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
 PKG_LICENSE:=GPLv2
@@ -35,6 +35,7 @@ define Package/motion
 endef
 
 define Package/motion/conffiles
+/etc/config/motion
 /etc/motion.conf
 endef
 
@@ -50,7 +51,9 @@ CONFIGURE_ARGS+= \
        --without-webp
 
 define Package/motion/install
-       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d
+       $(INSTALL_CONF) ./files/motion.conf $(1)/etc/config/motion
+       $(INSTALL_BIN) ./files/motion.init $(1)/etc/init.d/motion
        $(CP) $(PKG_BUILD_DIR)/motion-dist.conf $(1)/etc/motion.conf
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/motion $(1)/usr/bin/
diff --git a/multimedia/motion/files/motion.conf b/multimedia/motion/files/motion.conf
new file mode 100644 (file)
index 0000000..3155b5e
--- /dev/null
@@ -0,0 +1,2 @@
+config motion general
+       option enabled '0'
diff --git a/multimedia/motion/files/motion.init b/multimedia/motion/files/motion.init
new file mode 100644 (file)
index 0000000..2aae920
--- /dev/null
@@ -0,0 +1,22 @@
+#!/bin/sh /etc/rc.common
+
+START=94
+USE_PROCD=1
+
+PROG="/usr/bin/motion"
+CONF="/etc/motion.conf"
+
+start_service() {
+       local enabled
+
+       config_load "motion"
+       config_get_bool enabled "general" "enabled" 0
+       [ "$enabled" -gt 0 ] || return 1
+
+       procd_open_instance
+
+       procd_set_param command "$PROG"
+       procd_append_param command -c "$CONF"
+
+       procd_close_instance
+}