postgresql: update to version 14.5
authorDaniel Golle <daniel@makrotopia.org>
Wed, 7 Sep 2022 18:25:23 +0000 (19:25 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 7 Sep 2022 21:56:35 +0000 (22:56 +0100)
Release date: 2022-08-11
Adresses CVE-2022-2625.
For more details, please see the release notes[1].

[1]: https://www.postgresql.org/docs/release/14.5/
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/postgresql/Makefile
libs/postgresql/patches/700-no-arm-crc-march-change.patch
libs/postgresql/patches/900-pg_ctl-setuid.patch

index 4663911112004f30bc1791e401b1e1a67ff89cf1..a4bba598b53909de00fb407d6a8e9ad1e7382c59 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=14.2
+PKG_VERSION:=14.5
 PKG_RELEASE:=$(AUTORELEASE)
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=PostgreSQL
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=\
        http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
        ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
 
-PKG_HASH:=2cf78b2e468912f8101d695db5340cf313c2e9f68a612fb71427524e8c9a977a
+PKG_HASH:=d4f72cb5fb857c9a9f75ec8cf091a1771272802f2178f0b2e65b7b6ff64f4a30
 
 PKG_USE_MIPS16:=0
 PKG_FIXUP:=autoreconf
index 1f4449236539f2d751168e0a4eaa93ba38fc7a38..05d3198c2e9fa6205b4935341d5b087b9c3b3aad 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2127,9 +2127,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
+@@ -2141,9 +2141,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([], [
  # flags. If not, check if adding -march=armv8-a+crc flag helps.
  # CFLAGS_ARMV8_CRC32C is set if the extra flag is required.
  PGAC_ARMV8_CRC32C_INTRINSICS([])
index 8f86c35d76d36874cdcc0b38f14b4e88914a6c98..d114a820eacde6cd815e89a75b742dbc85acfd2c 100644 (file)
@@ -8,7 +8,7 @@
  static char *argv0 = NULL;
  static bool allow_core_files = false;
  static time_t start_time;
-@@ -2049,6 +2050,9 @@ do_help(void)
+@@ -2081,6 +2082,9 @@ do_help(void)
  #endif
        printf(_("  -s, --silent           only print errors, no informational messages\n"));
        printf(_("  -t, --timeout=SECS     seconds to wait when using -w option\n"));
@@ -18,7 +18,7 @@
        printf(_("  -V, --version          output version information, then exit\n"));
        printf(_("  -w, --wait             wait until operation completes (default)\n"));
        printf(_("  -W, --no-wait          do not wait until operation completes\n"));
-@@ -2261,6 +2265,7 @@ main(int argc, char **argv)
+@@ -2293,6 +2297,7 @@ main(int argc, char **argv)
                {"options", required_argument, NULL, 'o'},
                {"silent", no_argument, NULL, 's'},
                {"timeout", required_argument, NULL, 't'},
@@ -26,7 +26,7 @@
                {"core-files", no_argument, NULL, 'c'},
                {"wait", no_argument, NULL, 'w'},
                {"no-wait", no_argument, NULL, 'W'},
-@@ -2301,20 +2306,6 @@ main(int argc, char **argv)
+@@ -2333,20 +2338,6 @@ main(int argc, char **argv)
                }
        }
  
@@ -47,7 +47,7 @@
  
        env_wait = getenv("PGCTLTIMEOUT");
        if (env_wait != NULL)
-@@ -2400,11 +2391,15 @@ main(int argc, char **argv)
+@@ -2432,11 +2423,15 @@ main(int argc, char **argv)
                                        wait_seconds_arg = true;
                                        break;
                                case 'U':
@@ -63,7 +63,7 @@
                                        break;
                                case 'w':
                                        do_wait = true;
-@@ -2486,6 +2481,41 @@ main(int argc, char **argv)
+@@ -2518,6 +2513,41 @@ main(int argc, char **argv)
                exit(1);
        }