cryptodev-linux: bump to 1.8 2277/head
authornotnyt <nyt-github@countercultured.net>
Sun, 17 Jan 2016 21:19:29 +0000 (16:19 -0500)
committernotnyt <nyt-github@countercultured.net>
Sun, 17 Jan 2016 21:19:29 +0000 (16:19 -0500)
This fixes compile time errors using kernel 4.3 and above

Signed-off-by: Rob Mosher <nyt-openwrt@countercultured.net>
utils/cryptodev-linux/Makefile
utils/cryptodev-linux/patches/001-no-get-unused-fd.patch [deleted file]

index 507cf4f5f9ef74fd22cda552997e9ebf059dc317..a304472d20be8ecddf776786f66f6d4afaf10075 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=cryptodev-linux
-PKG_VERSION:=1.7
-PKG_RELEASE:=2
+PKG_VERSION:=1.8
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.gna.org/cryptodev-linux/
-PKG_MD5SUM:=0b63b3481cf2c90386b35f057481d36b
+PKG_MD5SUM:=02644cc4cd02301e0b503a332eb2f0b5
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
diff --git a/utils/cryptodev-linux/patches/001-no-get-unused-fd.patch b/utils/cryptodev-linux/patches/001-no-get-unused-fd.patch
deleted file mode 100644 (file)
index e3308bb..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: cryptodev-linux-1.7/ioctl.c
-===================================================================
---- cryptodev-linux-1.7.orig/ioctl.c
-+++ cryptodev-linux-1.7/ioctl.c
-@@ -546,7 +546,7 @@ static int
- clonefd(struct file *filp)
- {
-       int ret;
--      ret = get_unused_fd();
-+      ret = get_unused_fd_flags(0);
-       if (ret >= 0) {
-                       get_file(filp);
-                       fd_install(ret, filp);