mac80211: ath9k: enable OEM cards support on x86
authorRafał Dzięgiel <rafostar.github@gmail.com>
Sat, 1 Aug 2020 21:09:20 +0000 (23:09 +0200)
committerDavid Bauer <mail@david-bauer.net>
Wed, 4 Nov 2020 22:58:50 +0000 (23:58 +0100)
A lot of devices running OpenWrt x86 arch (32 or 64 bit) are either
"home-made routers" or devices that use PC class OEM components.

This commit enables OEM cards support on those devices by default.

Signed-off-by: Rafał Dzięgiel <rafostar.github@gmail.com>
[reformat commit message]
Signed-off-by: David Bauer <mail@david-bauer.net>
package/kernel/mac80211/ath.mk

index 5db4be8daa760e7391d773e1d89553bab526944f..be3f4ed1362c14c11ad2d7e8ca95b507b171991d 100644 (file)
@@ -218,6 +218,7 @@ define KernelPackage/ath9k/config
        config ATH9K_SUPPORT_PCOEM
                bool "Support chips used in PC OEM cards"
                depends on PACKAGE_kmod-ath9k
+               default y if (x86_64 || i386)
 
        config ATH9K_TX99
                bool "Enable TX99 support (WARNING: testing only, breaks normal operation!)"