sysrepo: update to 0.7.4 6358/head
authorMatija Amidzic <matija.amidzic@sartura.hr>
Tue, 26 Jun 2018 10:48:02 +0000 (12:48 +0200)
committerMatija Amidzic <matija.amidzic@sartura.hr>
Mon, 2 Jul 2018 11:39:20 +0000 (13:39 +0200)
Signed-off-by: Matija Amidzic <matija.amidzic@sartura.hr>
net/sysrepo/Makefile
net/sysrepo/files/libsysrepo.default

index a916f9cb20fd10cd23c68b5c7d05418829cd4f04..a3b701166e6b8f711b06262f893625cc535eb871 100644 (file)
@@ -11,12 +11,12 @@ PKG_LICENSE:=ASL-2.0
 PKG_MAINTAINER:=Mislav Novakovic <mislav.novakovic@sartura.hr>
 
 PKG_NAME:=sysrepo
-PKG_VERSION:=0.7.3
+PKG_VERSION:=0.7.4
 PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=91e65c6f7d8826197b2806ab6d5466d16882b07f
-PKG_MIRROR_HASH:=41662c158d5eac3e6c9f400517bd02b1967632f3d8b3516523da669bbd1c28c4
+PKG_SOURCE_VERSION:=724a62fa830df7fcb2736b1ec41b320abe5064d2
+PKG_MIRROR_HASH:=19b864c52a35fd71398b2c965f87c37901a7056a2afd6b740105a5235bd459b1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/sysrepo/sysrepo.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION)
@@ -128,7 +128,7 @@ define Package/libsysrepo/install
 
        $(INSTALL_DIR) $(1)/etc/sysrepo/yang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/yang/ietf-netconf-acm@2012-02-22.yang $(1)/etc/sysrepo/yang/ietf-netconf-acm@2012-02-22.yang
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/yang/ietf-netconf-notifications.yang $(1)/etc/sysrepo/yang/ietf-netconf-notifications@2012-02-06..yang
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/yang/ietf-netconf-notifications.yang $(1)/etc/sysrepo/yang/ietf-netconf-notifications@2012-02-06.yang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/yang/nc-notifications.yang $(1)/etc/sysrepo/yang/nc-notifications@2008-07-14.yang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/yang/notifications.yang $(1)/etc/sysrepo/yang/notifications@2008-07-14.yang
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/yang/ietf-netconf@2011-06-01.yang $(1)/etc/sysrepo/yang/ietf-netconf@2011-06-01.yang
index 35b56f67de51e7b4e9f0c1567ee82eda7cae8fe9..274a6c06642b9762f6466cbb4c22bfd35959e095 100644 (file)
@@ -3,30 +3,36 @@
 # Warning, problems can occur if the device restarts in the middle of this uci-default script
 
 if [ -x /bin/sysrepoctl ]; then
-       match=$(sysrepoctl -l | grep "ietf-netconf-acm ")
+       match=$(sysrepoctl -l | grep "notifications ")
        if [ ! "$match" ]; then
-               sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-acm@2012-02-22.yang -p 644
+               sysrepoctl --install --yang=/etc/sysrepo/yang/notifications@2008-07-14.yang -p 666
        fi
 
-       match=$(sysrepoctl -l | grep "ietf-netconf-notifications ")
+       match=$(sysrepoctl -l | grep "nc-notifications ")
        if [ ! "$match" ]; then
-               sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-notifications@2012-02-06..yang -p 600
+               sysrepoctl --install --yang=/etc/sysrepo/yang/nc-notifications@2008-07-14.yang -p 666
        fi
 
-       match=$(sysrepoctl -l | grep "nc-notifications ")
+       match=$(sysrepoctl -l | grep "ietf-netconf-acm ")
        if [ ! "$match" ]; then
-               sysrepoctl --install --yang=/etc/sysrepo/yang/nc-notifications@2008-07-14.yang -p 666
+               sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-acm@2012-02-22.yang -p 644
        fi
 
-       match=$(sysrepoctl -l | grep "notifications ")
+       match=$(sysrepoctl -l | grep "ietf-netconf-notifications ")
        if [ ! "$match" ]; then
-               sysrepoctl --install --yang=/etc/sysrepo/yang/notifications@2008-07-14.yang -p 666
+               sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf-notifications@2012-02-06.yang -p 600
        fi
 
        match=$(sysrepoctl -l | grep "ietf-netconf ")
        if [ ! "$match" ]; then
                sysrepoctl --install --yang=/etc/sysrepo/yang/ietf-netconf@2011-06-01.yang -p 600
        fi
+       sysrepoctl -m ietf-netconf -e writable-running
+       sysrepoctl -m ietf-netconf -e candidate
+       sysrepoctl -m ietf-netconf -e rollback-on-error
+       sysrepoctl -m ietf-netconf -e validate
+       sysrepoctl -m ietf-netconf -e startup
+       sysrepoctl -m ietf-netconf -e xpath
 fi
 
 exit 0