antfs: require kernel version 5.10 to build
authorJohn Thomson <git@johnthomson.fastmail.com.au>
Wed, 27 Apr 2022 03:10:37 +0000 (13:10 +1000)
committerRosen Penev <rosenp@gmail.com>
Sun, 1 May 2022 00:32:41 +0000 (17:32 -0700)
ANTFS does not compile with OpenWrt's current testing kernel 5.15,
as it needs to be modified for the Linux 5.12 idmapped mounts changes
2f221d6f7b88 ("attr: handle idmapped mounts")
https://lore.kernel.org/all/20210121131959.646623-1-christian.brauner@ubuntu.com/

Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
kernel/antfs/Makefile

index e200c5d9a6b8e9858d78ab1ee3ca52b73bb3d29e..1137b5bd8daca58f8aa2af0bc439ff967cf83251 100644 (file)
@@ -20,7 +20,7 @@ define KernelPackage/fs-antfs
        TITLE:=AVM NTFS Read/Write Driver
        FILES:=$(PKG_BUILD_DIR)/antfs.ko
        AUTOLOAD:=$(call AutoLoad,30,antfs,1)
-       DEPENDS:=+kmod-nls-base
+       DEPENDS:=+kmod-nls-base @LINUX_5_10
 endef
 
 define KernelPackage/fs-antfs/description