spandsp: remove $(FPIC) from TARGET_CFLAGS
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 09:56:13 +0000 (10:56 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 09:56:15 +0000 (10:56 +0100)
spandsp already makes sure that the compiler emits position-independent
code. Adding $(FPIC) makes no difference. In addition the spandsp build
system puts its own flag behind the CFLAGS, overriding whatever was set
before.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/spandsp/Makefile

index 9236282848d6721b940f8ee5b8921aff65e55777..e326bc757aaecc6132ce5581f81e7780e016a296 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014 - 2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -33,8 +33,6 @@ define Package/libspandsp
   DEPENDS:=+libtiff
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libspandsp* $(1)/usr/lib/