hnetd: add PKG_MIRROR_HASH, refresh patch
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 27 Feb 2022 12:30:21 +0000 (13:30 +0100)
committerPaul Spooren <mail@aparcar.org>
Mon, 28 Feb 2022 11:43:08 +0000 (12:43 +0100)
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
hnetd/Makefile
hnetd/patches/0001-dtls.c-Update-openssl-API-to-1.1.0.patch

index 86899728f8e48712ae90b74d43e7f2401f48c382..57d13a428fe5a1849c21d1b1915ec0ca2efa282e 100644 (file)
@@ -13,6 +13,7 @@ PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/sbyx/hnetd.git
+PKG_MIRROR_HASH:=5f06f72d5620de25e29b3e34a6524aebd8e7b5c8160cfd29135a6ec0f12ffa3e
 PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
 PKG_LICENSE:=GPL-2.0
 
index 36cce7d5d6dc10007cb76fb92404e24f22dc2e0f..e377366b81661ca06919ef47808548b80294ce59 100644 (file)
@@ -10,8 +10,6 @@ Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
  src/dtls.c | 20 +++++++++++++++++---
  1 file changed, 17 insertions(+), 3 deletions(-)
 
-diff --git a/src/dtls.c b/src/dtls.c
-index ed5d408..511f724 100644
 --- a/src/dtls.c
 +++ b/src/dtls.c
 @@ -38,6 +38,7 @@
@@ -51,7 +49,7 @@ index ed5d408..511f724 100644
  
    if (!d)
      {
-@@ -916,7 +930,7 @@ bool dtls_set_local_cert(dtls d, const char *certfile, const char *pkfile)
+@@ -916,7 +930,7 @@ bool dtls_set_local_cert(dtls d, const c
                       |SSL_VERIFY_FAIL_IF_NO_PEER_CERT
  #endif /* DTLS_OPENSSL */
                       , _verify_cert_cb);
@@ -60,7 +58,7 @@ index ed5d408..511f724 100644
  
  #ifndef USE_ONE_CONTEXT
    R1("client cert",
-@@ -928,7 +942,7 @@ bool dtls_set_local_cert(dtls d, const char *certfile, const char *pkfile)
+@@ -928,7 +942,7 @@ bool dtls_set_local_cert(dtls d, const c
                       |SSL_VERIFY_PEER_FAIL_IF_NO_PEER_CERT
  #endif /* DTLS_OPENSSL */
                       , _verify_cert_cb);