add preliminary support for the Atheros PB42 board
authorGabor Juhos <juhosg@openwrt.org>
Sun, 4 Jan 2009 19:06:00 +0000 (19:06 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 4 Jan 2009 19:06:00 +0000 (19:06 +0000)
SVN-Revision: 13860

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h

index 4f6340581f5cbf40e059387851e656497c417297..518f2975f3940ae9f4ee8154c5b731e4716749a0 100644 (file)
@@ -7,11 +7,12 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_UBNT=y
-CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WNR2000=y
+CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
index 15fb517b7bbc527f6958c5206a140bc9b7fede5a..502f458ed64e225acf2d3225dcd91820ed08ebc8 100644 (file)
@@ -7,11 +7,12 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_UBNT=y
-CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WNR2000=y
+CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
index ef6b85272d1af80f712622b4b0463265df8532d3..522f1c7e154b553ffa0f3b84e91ccb6c4425d312 100644 (file)
@@ -7,11 +7,12 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_UBNT=y
-CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WNR2000=y
+CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
index 64fe5555c70c7671d163865a242d6514652d2c4b..09ffdfe07f73973eb414165fdb1357bb481af348 100644 (file)
@@ -120,6 +120,8 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_RS    9       /* Ubiquiti RouterStation */
 #define AR71XX_MACH_UBNT_LSX   10      /* Ubiquiti LSX */
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
+#define AR71XX_MACH_PB42       12      /* Atheros PB42 */
+
 
 /*
  * PLL block
index e10a7c95729c694aff7347427af28542caad2611..d8e22470f40b71b474ad67b01da39c32c2c80404 100644 (file)
@@ -10,6 +10,10 @@ config AR71XX_MACH_AP83
        bool "Atheros AP83 board support"
        default y
 
+config AR71XX_MACH_PB42
+       bool "Atheros PB42 board support"
+       default y
+
 config AR71XX_MACH_AW_NR580
        bool "AzureWave AW-NR580 board support"
        default y
index 588d23f6a92b0769b088b578e7498c23d4b898eb..b634e36d68833ca2c5a1d4499ce4de2fcc5733f3 100644 (file)
@@ -13,8 +13,9 @@ obj-y := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
+obj-$(CONFIG_AR71XX_MACH_PB42)         += mach-pb42.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
-obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
+obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c
new file mode 100644 (file)
index 0000000..0379692
--- /dev/null
@@ -0,0 +1,68 @@
+/*
+ *  Atheros PB42 board support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static struct spi_board_info pb42_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+       }
+};
+
+static struct ar71xx_pci_irq pb42_pci_irqs[] __initdata = {
+       {
+               .slot   = 0,
+               .pin    = 1,
+               .irq    = AR71XX_PCI_IRQ_DEV0,
+       }, {
+               .slot   = 1,
+               .pin    = 1,
+               .irq    = AR71XX_PCI_IRQ_DEV1,
+       }, {
+               .slot   = 2,
+               .pin    = 1,
+               .irq    = AR71XX_PCI_IRQ_DEV2,
+       }
+};
+
+static void __init pb42_init(void)
+{
+       ar71xx_add_device_spi(NULL, pb42_spi_info,
+                               ARRAY_SIZE(pb42_spi_info));
+
+       ar71xx_add_device_mdio(0xffe0ffff);
+
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ar71xx_eth0_data.phy_mask = 0x000f0000;
+
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth1_data.phy_mask = 0x00100000;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       ar71xx_add_device_usb();
+
+       ar71xx_pci_init(ARRAY_SIZE(pb42_pci_irqs), pb42_pci_irqs);
+}
+
+MIPS_MACHINE(AR71XX_MACH_PB42, "Atheros PB42", pb42_init);
index f9984ca1c49e201dc906c851b0d93b072221cc73..bb6a112a2373ae7a1f28e30b3e1c0b0145ca0856 100644 (file)
@@ -61,6 +61,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "WNR2000",
                .mach_type      = AR71XX_MACH_WNR2000,
+       }, {
+               .name           = "PB42",
+               .mach_type      = AR71XX_MACH_PB42,
        }
 };
 
index 64fe5555c70c7671d163865a242d6514652d2c4b..3895b21e4cdecf749c2416347bd66f28ec74ec21 100644 (file)
@@ -120,6 +120,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_RS    9       /* Ubiquiti RouterStation */
 #define AR71XX_MACH_UBNT_LSX   10      /* Ubiquiti LSX */
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
+#define AR71XX_MACH_PB42       12      /* Atheros PB42 */
 
 /*
  * PLL block