ola: enable and ship web stuff
authorDaniel Golle <daniel@makrotopia.org>
Thu, 21 Jun 2018 09:55:02 +0000 (11:55 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 23 Jun 2018 09:04:24 +0000 (11:04 +0200)
Make OLA more useful for untrained users which depend on the built-in
webserver. We may split the ola package into smaller parts to allow
not having web-stuff in case this breaks the space-constraints for some
users.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
net/ola/Makefile

index ec84724c8af1544350ae79f45152205e6d5ee4d8..bbe45c26f68edaacf051b91a9e308891148046ef 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ola
 PKG_VERSION:=0.10.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/OpenLightingProject/ola.git
@@ -38,7 +38,7 @@ define Package/ola
   TITLE:=Open Lighting Architecture Daemon
   URL:=https://www.openlighting.org/
   MAINTAINER:=Christian Beier <dontmind@freeshell.org>
-  DEPENDS:=+protobuf +libusb-1.0 +libuuid +libstdcpp +libpthread +librt +zlib +libncurses +liblo
+  DEPENDS:=+protobuf +libusb-1.0 +libuuid +libstdcpp +libpthread +librt +zlib +libncurses +liblo +libmicrohttpd
 endef
 
 define Package/ola/description
@@ -52,7 +52,6 @@ CONFIGURE_ARGS += \
        --disable-static \
        --disable-fatal-warnings \
        --disable-unittests \
-       --disable-http \
        --without-dns-sd \
        --with-ola-protoc-plugin=$(STAGING_DIR_HOSTPKG)/bin/ola_protoc_plugin
 
@@ -102,6 +101,9 @@ define Package/ola/install
 
        $(INSTALL_DIR) $(1)/usr/share/ola/pids
        $(CP) $(PKG_INSTALL_DIR)/usr/share/ola/pids/* $(1)/usr/share/ola/pids
+
+       $(INSTALL_DIR) $(1)/usr/share/olad/www
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/olad/www/* $(1)/usr/share/olad/www
 endef
 
 define Package/ola/postinst