projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
69aeb3a
)
autotools.mk: allow autogen.sh / autoreconf to fail (for now)
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 8 Dec 2010 01:19:52 +0000
(
01:19
+0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 8 Dec 2010 01:19:52 +0000
(
01:19
+0000)
SVN-Revision: 24320
include/autotools.mk
patch
|
blob
|
history
diff --git
a/include/autotools.mk
b/include/autotools.mk
index 32036046824620d5d7fd6ca25b10115c1ad66d54..df5e85a5f5a07b6bab9791b436732886b7ea1f17 100644
(file)
--- a/
include/autotools.mk
+++ b/
include/autotools.mk
@@
-25,10
+25,10
@@
endef
define autoreconf
(cd $(PKG_BUILD_DIR); \
if [ -x ./autogen.sh ]; then \
- ./autogen.sh; \
+ ./autogen.sh
|| true
; \
elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
- $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+ $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS)
|| true
; \
fi \
);
endef