lualane: avoid luajit dependency 7796/head
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 28 Dec 2018 12:18:38 +0000 (10:18 -0200)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Fri, 28 Dec 2018 12:27:17 +0000 (10:27 -0200)
Set LUA_LIBS=-llua manually to avoid picking up libluajit.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lang/lualanes/Makefile

index 79bbc14f5c401cd1cd241b410c23382abdc1afe2..b95b625f009847a22dc0421e647f00d02b4a6aae 100644 (file)
@@ -42,6 +42,8 @@ define Build/Compile
         CC="$(TARGET_CC)" \
         LUA="$(STAGING_DIR_HOSTPKG)/bin/lua" \
         LUAC="$(STAGING_DIR_HOSTPKG)/bin/luac" \
+       LUA_FLAGS= \
+       LUA_LIBS=-llua \
         OPT_FLAGS="$(TARGET_CFLAGS) -Dpthread_yield=sched_yield"
 endef