icu: fix CVE-2017-14952 Double-Free Vulnerability
authorHirokazu MORIKAWA <morikw2@gmail.com>
Tue, 24 Oct 2017 02:51:14 +0000 (11:51 +0900)
committerYousong Zhou <yszhou4tech@gmail.com>
Tue, 24 Oct 2017 07:35:19 +0000 (02:35 -0500)
http://www.sourcebrella.com/blog/double-free-vulnerability-international-components-unicode-icu/

https://security-tracker.debian.org/tracker/CVE-2017-14952

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
libs/icu/Makefile
libs/icu/patches/CVE-2017-14952.patch [new file with mode: 0644]

index aa86869db1ad44e8f908e9ab489d81d928b54104..2bed85af89150fde57de0f4c9c3a43ee729e4747 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icu4c
 PKG_VERSION:=59.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-59_1-src.tgz
 PKG_SOURCE_URL:=http://download.icu-project.org/files/$(PKG_NAME)/$(PKG_VERSION)
diff --git a/libs/icu/patches/CVE-2017-14952.patch b/libs/icu/patches/CVE-2017-14952.patch
new file mode 100644 (file)
index 0000000..f353ac7
--- /dev/null
@@ -0,0 +1,10 @@
+Index: source/i18n/zonemeta.cpp
+===================================================================
+--- source/i18n/zonemeta.cpp   (revision 40283)
++++ source/i18n/zonemeta.cpp   (revision 40324)
+@@ -691,5 +691,4 @@
+                     if (U_FAILURE(status)) {
+                         delete mzMappings;
+-                        deleteOlsonToMetaMappingEntry(entry);
+                         uprv_free(entry);
+                         break;