stress-ng: add libjpeg dep
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 22 Aug 2022 13:34:49 +0000 (16:34 +0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 23 Aug 2022 23:07:18 +0000 (01:07 +0200)
Fixes: https://github.com/openwrt/packages/issues/19210
If libjpeg isn't selected by another package, all is fine.
But if it is selected, the stress-ng build will see it and try to build the
jpeg stressor. This would usually fail sometime and link-time.

In any case, it's better to just pick-up libjpeg as a dependency of
stress-ng. If people want to stress their system with this tool, they can
probably expect libjpeg as well.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
utils/stress-ng/Makefile

index bfee2ee37eceecc175fd0bb24778c74cff507497..30590ccd10632e9465a0f67313815ac7b2de1efb 100644 (file)
@@ -27,7 +27,7 @@ define Package/stress-ng
   CATEGORY:=Utilities
   TITLE:=stress-ng is a stress test utility
   URL:=https://github.com/ColinIanKing/stress-ng
-  DEPENDS:=+zlib +libbsd +libaio +libsctp +libkmod +libatomic
+  DEPENDS:=+zlib +libbsd +libaio +libsctp +libkmod +libatomic +libjpeg
 endef
 
 define Package/stress-ng/description