ath25: refresh patches for kernel 5.4
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 13 Apr 2020 17:11:20 +0000 (19:11 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 6 Sep 2020 17:49:13 +0000 (19:49 +0200)
Refresh patches to make them apply to kernel 5.4.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath25/patches-5.4/107-ar5312_gpio.patch
target/linux/ath25/patches-5.4/108-ar2315_gpio.patch
target/linux/ath25/patches-5.4/110-ar2313_ethernet.patch
target/linux/ath25/patches-5.4/120-spiflash.patch
target/linux/ath25/patches-5.4/130-watchdog.patch
target/linux/ath25/patches-5.4/140-redboot_boardconfig.patch
target/linux/ath25/patches-5.4/141-redboot_partition_scan.patch
target/linux/ath25/patches-5.4/142-redboot_various_erase_size_fix.patch

index e74e20b05a4e11de28a129a757166acdefa6047f..cd7b27d636395ba77ec3c3349ff14e9cd3f4de98 100644 (file)
@@ -52,7 +52,7 @@
                if (!ath25_board.radio)
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -105,6 +105,13 @@ config GPIO_AMDPT
+@@ -113,6 +113,13 @@ config GPIO_AMDPT
          driver for GPIO functionality on Promontory IOHub
          Require ACPI ASL code to enumerate as a platform device.
  
        depends on (ARCH_ASPEED || COMPILE_TEST) && OF_GPIO
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -29,6 +29,7 @@ obj-$(CONFIG_GPIO_ALTERA)    += gpio-alte
- obj-$(CONFIG_GPIO_ALTERA_A10SR)       += gpio-altera-a10sr.o
- obj-$(CONFIG_GPIO_AMD8111)    += gpio-amd8111.o
- obj-$(CONFIG_GPIO_AMDPT)      += gpio-amdpt.o
-+obj-$(CONFIG_GPIO_AR5312)     += gpio-ar5312.o
- obj-$(CONFIG_GPIO_ARIZONA)    += gpio-arizona.o
- obj-$(CONFIG_GPIO_ATH79)      += gpio-ath79.o
- obj-$(CONFIG_GPIO_ASPEED)     += gpio-aspeed.o
+@@ -30,6 +30,7 @@ obj-$(CONFIG_GPIO_ALTERA)            += gpio-alt
+ obj-$(CONFIG_GPIO_AMD8111)            += gpio-amd8111.o
+ obj-$(CONFIG_GPIO_AMD_FCH)            += gpio-amd-fch.o
+ obj-$(CONFIG_GPIO_AMDPT)              += gpio-amdpt.o
++obj-$(CONFIG_GPIO_AR5312)             += gpio-ar5312.o
+ obj-$(CONFIG_GPIO_ARIZONA)            += gpio-arizona.o
+ obj-$(CONFIG_GPIO_ASPEED)             += gpio-aspeed.o
+ obj-$(CONFIG_GPIO_ATH79)              += gpio-ath79.o
 --- /dev/null
 +++ b/drivers/gpio/gpio-ar5312.c
 @@ -0,0 +1,121 @@
 +subsys_initcall(ar5312_gpio_init);
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -175,6 +175,7 @@ config ATH25
+@@ -189,6 +189,7 @@ config ATH25
        select CEVT_R4K
        select CSRC_R4K
        select DMA_NONCOHERENT
index 749b308b89f12a385d7dab4ba5edc47cdb4f9b43..e198cecf15d84a30eb34c0fe8d2e6eabde188d4c 100644 (file)
@@ -75,7 +75,7 @@
         * workaround. Attempt to jump to the mips reset location -
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -105,6 +105,13 @@ config GPIO_AMDPT
+@@ -113,6 +113,13 @@ config GPIO_AMDPT
          driver for GPIO functionality on Promontory IOHub
          Require ACPI ASL code to enumerate as a platform device.
  
        default y if SOC_AR5312
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -29,6 +29,7 @@ obj-$(CONFIG_GPIO_ALTERA)    += gpio-alte
- obj-$(CONFIG_GPIO_ALTERA_A10SR)       += gpio-altera-a10sr.o
- obj-$(CONFIG_GPIO_AMD8111)    += gpio-amd8111.o
- obj-$(CONFIG_GPIO_AMDPT)      += gpio-amdpt.o
-+obj-$(CONFIG_GPIO_AR2315)     += gpio-ar2315.o
- obj-$(CONFIG_GPIO_AR5312)     += gpio-ar5312.o
- obj-$(CONFIG_GPIO_ARIZONA)    += gpio-arizona.o
- obj-$(CONFIG_GPIO_ATH79)      += gpio-ath79.o
+@@ -30,6 +30,7 @@ obj-$(CONFIG_GPIO_ALTERA)            += gpio-alt
+ obj-$(CONFIG_GPIO_AMD8111)            += gpio-amd8111.o
+ obj-$(CONFIG_GPIO_AMD_FCH)            += gpio-amd-fch.o
+ obj-$(CONFIG_GPIO_AMDPT)              += gpio-amdpt.o
++obj-$(CONFIG_GPIO_AR2315)             += gpio-ar2315.o
+ obj-$(CONFIG_GPIO_AR5312)             += gpio-ar5312.o
+ obj-$(CONFIG_GPIO_ARIZONA)            += gpio-arizona.o
+ obj-$(CONFIG_GPIO_ASPEED)             += gpio-aspeed.o
 --- /dev/null
 +++ b/drivers/gpio/gpio-ar2315.c
 @@ -0,0 +1,233 @@
index a2b149225089ea9991c34a11967b645a14b96186..916e57cb36928300e613382edb01a7d291380dc3 100644 (file)
@@ -1,22 +1,22 @@
 --- a/drivers/net/ethernet/atheros/Makefile
 +++ b/drivers/net/ethernet/atheros/Makefile
-@@ -8,3 +8,4 @@ obj-$(CONFIG_ATL2) += atlx/
+@@ -9,3 +9,4 @@ obj-$(CONFIG_ATL2) += atlx/
  obj-$(CONFIG_ATL1E) += atl1e/
  obj-$(CONFIG_ATL1C) += atl1c/
  obj-$(CONFIG_ALX) += alx/
 +obj-$(CONFIG_NET_AR231X) += ar231x/
 --- a/drivers/net/ethernet/atheros/Kconfig
 +++ b/drivers/net/ethernet/atheros/Kconfig
-@@ -5,7 +5,7 @@
+@@ -6,7 +6,7 @@
  config NET_VENDOR_ATHEROS
        bool "Atheros devices"
        default y
--      depends on PCI
-+      depends on (PCI || ATH25)
+-      depends on (PCI || ATH79)
++      depends on (PCI || ATH25 || ATH79)
        ---help---
          If you have a network (Ethernet) card belonging to this class, say Y.
  
-@@ -78,4 +78,10 @@ config ALX
+@@ -87,4 +87,10 @@ config ALX
          To compile this driver as a module, choose M here.  The module
          will be called alx.
  
 +
  void __init ath25_serial_setup(u32 mapbase, int irq, unsigned int uartclk)
  {
-       struct uart_port s;
+ #ifdef CONFIG_SERIAL_8250_CONSOLE
 --- a/arch/mips/include/asm/mach-ath25/ath25_platform.h
 +++ b/arch/mips/include/asm/mach-ath25/ath25_platform.h
 @@ -71,4 +71,15 @@ struct ar231x_board_config {
index 0a2161fb7eff0cf08b4a4439aed7d7a2393a8ca6..d49669b976b3bf461bcd18603691b739d9bcc2d6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/Kconfig
 +++ b/drivers/mtd/devices/Kconfig
-@@ -130,6 +130,10 @@ config MTD_BCM47XXSFLASH
+@@ -114,6 +114,10 @@ config MTD_BCM47XXSFLASH
          registered by bcma as platform devices. This enables driver for
          serial flash memories.
  
@@ -13,7 +13,7 @@
        help
 --- a/drivers/mtd/devices/Makefile
 +++ b/drivers/mtd/devices/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_MTD_M25P80)     += m25p80.o
+@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_DATAFLASH)  += mtd_dataf
  obj-$(CONFIG_MTD_MCHP23K256)  += mchp23k256.o
  obj-$(CONFIG_MTD_SPEAR_SMI)   += spear_smi.o
  obj-$(CONFIG_MTD_SST25L)      += sst25l.o
index 01904d69a54e77a2991c43148484ecdcc9184f35..8a5bd8341879b0e4d0da9f216ab7020b4219f790 100644 (file)
 +MODULE_ALIAS("platform:" DRIVER_NAME);
 --- a/drivers/watchdog/Kconfig
 +++ b/drivers/watchdog/Kconfig
-@@ -1647,6 +1647,13 @@ config PIC32_DMT
+@@ -1830,6 +1830,13 @@ config PIC32_DMT
          To compile this driver as a loadable module, choose M here.
          The module will be called pic32-dmt.
  
  # POWERPC Architecture
 --- a/drivers/watchdog/Makefile
 +++ b/drivers/watchdog/Makefile
-@@ -166,6 +166,7 @@ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
+@@ -161,6 +161,7 @@ obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
  obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o
  obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
  obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
index 6aad761cb18e1592042924df7066a034aea2f2c2..0ffa12eec0d09e2899137fec5b6466b06337e356 100644 (file)
@@ -1,6 +1,6 @@
---- a/drivers/mtd/redboot.c
-+++ b/drivers/mtd/redboot.c
-@@ -30,6 +30,8 @@
+--- a/drivers/mtd/parsers/redboot.c
++++ b/drivers/mtd/parsers/redboot.c
+@@ -16,6 +16,8 @@
  #include <linux/mtd/partitions.h>
  #include <linux/module.h>
  
@@ -9,7 +9,7 @@
  struct fis_image_desc {
      unsigned char name[16];      // Null terminated name
      uint32_t    flash_base;    // Address within FLASH of image
-@@ -60,6 +62,7 @@ static int parse_redboot_partitions(stru
+@@ -67,6 +69,7 @@ static int parse_redboot_partitions(stru
                                    const struct mtd_partition **pparts,
                                    struct mtd_part_parser_data *data)
  {
@@ -17,7 +17,7 @@
        int nrparts = 0;
        struct fis_image_desc *buf;
        struct mtd_partition *parts;
-@@ -225,14 +228,15 @@ static int parse_redboot_partitions(stru
+@@ -234,14 +237,15 @@ static int parse_redboot_partitions(stru
                }
        }
  #endif
@@ -35,7 +35,7 @@
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        if (nulllen > 0) {
                strcpy(nullname, nullstring);
-@@ -251,6 +255,8 @@ static int parse_redboot_partitions(stru
+@@ -260,6 +264,8 @@ static int parse_redboot_partitions(stru
        }
  #endif
        for ( ; i<nrparts; i++) {
@@ -44,7 +44,7 @@
                parts[i].size = fl->img->size;
                parts[i].offset = fl->img->flash_base;
                parts[i].name = names;
-@@ -284,6 +290,13 @@ static int parse_redboot_partitions(stru
+@@ -293,6 +299,13 @@ static int parse_redboot_partitions(stru
                fl = fl->next;
                kfree(tmp_fl);
        }
index d1d281eaf4256a94545ebd60cd1482cd9f9a8934..3302d6d247c330871a3ad3effbc69e7ac1d2bdfa 100644 (file)
@@ -1,8 +1,8 @@
---- a/drivers/mtd/redboot.c
-+++ b/drivers/mtd/redboot.c
-@@ -79,12 +79,18 @@ static int parse_redboot_partitions(stru
-       static char nullstring[] = "unallocated";
- #endif
+--- a/drivers/mtd/parsers/redboot.c
++++ b/drivers/mtd/parsers/redboot.c
+@@ -88,12 +88,18 @@ static int parse_redboot_partitions(stru
+       parse_redboot_of(master);
  
 +      buf = vmalloc(master->erasesize);
 +      if (!buf)
@@ -19,7 +19,7 @@
                                return -EIO;
                        }
                        offset -= master->erasesize;
-@@ -97,10 +103,6 @@ static int parse_redboot_partitions(stru
+@@ -106,10 +112,6 @@ static int parse_redboot_partitions(stru
                                goto nogood;
                }
        }
@@ -30,7 +30,7 @@
  
        printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
               master->name, offset);
-@@ -173,6 +175,11 @@ static int parse_redboot_partitions(stru
+@@ -182,6 +184,11 @@ static int parse_redboot_partitions(stru
        }
        if (i == numslots) {
                /* Didn't find it */
index ce039df9f193bcb1d246157be63f1ae68519fab0..2ac0eb92bf15788950ce156c5f61b4e3b33db4e9 100644 (file)
@@ -1,7 +1,7 @@
---- a/drivers/mtd/redboot.c
-+++ b/drivers/mtd/redboot.c
-@@ -58,6 +58,22 @@ static inline int redboot_checksum(struc
-       return 1;
+--- a/drivers/mtd/parsers/redboot.c
++++ b/drivers/mtd/parsers/redboot.c
+@@ -65,6 +65,22 @@ static void parse_redboot_of(struct mtd_
+       directory = dirblock;
  }
  
 +static uint32_t mtd_get_offset_erasesize(struct mtd_info *mtd, uint64_t offset)
@@ -23,7 +23,7 @@
  static int parse_redboot_partitions(struct mtd_info *master,
                                    const struct mtd_partition **pparts,
                                    struct mtd_part_parser_data *data)
-@@ -74,6 +90,7 @@ static int parse_redboot_partitions(stru
+@@ -81,6 +97,7 @@ static int parse_redboot_partitions(stru
        int namelen = 0;
        int nulllen = 0;
        int numslots;
@@ -31,7 +31,7 @@
        unsigned long offset;
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        static char nullstring[] = "unallocated";
-@@ -186,7 +203,10 @@ static int parse_redboot_partitions(stru
+@@ -195,7 +212,10 @@ static int parse_redboot_partitions(stru
                goto out;
        }
  
@@ -43,7 +43,7 @@
                struct fis_list *new_fl, **prev;
  
                if (buf[i].name[0] == 0xff) {
-@@ -262,12 +282,13 @@ static int parse_redboot_partitions(stru
+@@ -271,12 +291,13 @@ static int parse_redboot_partitions(stru
        }
  #endif
        for ( ; i<nrparts; i++) {
@@ -59,7 +59,7 @@
                strcpy(names, fl->img->name);
  #ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
                if (!memcmp(names, "RedBoot", 8) ||
-@@ -297,7 +318,9 @@ static int parse_redboot_partitions(stru
+@@ -306,7 +327,9 @@ static int parse_redboot_partitions(stru
                fl = fl->next;
                kfree(tmp_fl);
        }