mediatek: remove left-over reference to make_gl_metadata.py
authorDaniel Golle <daniel@makrotopia.org>
Thu, 18 May 2023 10:21:48 +0000 (11:21 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Thu, 18 May 2023 10:24:07 +0000 (11:24 +0100)
When adding support for the GL.iNet GL-MT3000 a reference to the
non-existent make_gl_metadata.py script was accidentally added.
Remove it, flashing from vendor firmware also works fine without that.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/filogic.mk

index dcd048046cb7859c677ca0db2b33ddebde05be4a..5c8b47c662f3157e7f1d10f72a5ab609f20d6e7b 100644 (file)
@@ -53,9 +53,7 @@ metadata_gl_json = \
                        "revision": "$(call json_quote,$(REVISION))", \
                        "target": "$(call json_quote,$(TARGETID))", \
                        "board": "$(call json_quote,$(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)))" \
-               }, \
-               "upgrade_control":"$(shell python3 $(TOPDIR)/make_gl_metadata.py)", \
-               "release_note":"$(shell sed ':a;N;s/\n/\\n/g;s/\r/\\r/g;ta' $(TOPDIR)/gl_release_note)" \
+               } \
        }'
 
 define Build/append-gl-metadata