tinc: Bump to version 1.1 commit 3ee0d5dd
authorErwan MAS <erwan@mas.nom.fr>
Sun, 14 Feb 2021 19:21:34 +0000 (14:21 -0500)
committerErwan MAS <erwan@mas.nom.fr>
Sun, 14 Feb 2021 19:37:12 +0000 (14:37 -0500)
Signed-off-by: Erwan MAS <erwan@mas.nom.fr>
net/tinc/Makefile
net/tinc/files/tinc.init

index c8949b4d1ebe8a5e229d52890a7a2461a33d4013..be622479d850ea51fb347c3f9ed4b0e9e35aada7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2019 OpenWrt.org
+# Copyright (C) 2007-2021 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,22 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.36
-PKG_RELEASE:=3
+PKG_VERSION:=1.1-git
+PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://www.tinc-vpn.org/packages
-PKG_HASH:=40f73bb3facc480effe0e771442a706ff0488edea7a5f2505d4ccb2aa8163108
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=http://tinc-vpn.org/git/tinc
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=3ee0d5dd
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_MIRROR_MD5SUM:=
 
 PKG_CPE_ID:=cpe:/a:tinc:tinc
 
 PKG_BUILD_PARALLEL:=1
+PKG_CONFIG_DEPENDS:=zlib lzo openssl
+PKG_BUILD_DEPENDS:=zlib lzo openssl
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -25,7 +31,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblzo +libopenssl +kmod-tun +zlib
+  DEPENDS:=+kmod-tun +liblzo +libopenssl +librt +zlib
   TITLE:=VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
   MAINTAINER:=Saverio Proto <zioproto@gmail.com>
@@ -41,14 +47,17 @@ TARGET_CFLAGS += -std=gnu99
 
 CONFIGURE_ARGS += \
        --with-kernel="$(LINUX_DIR)" \
-       --with-zlib="$(STAGING_DIR)/usr" \
-       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo"
+       --disable-curses \
+       --disable-readline \
+       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo" \
+       --with-zlib="$(STAGING_DIR)/usr"
 
 CONFIGURE_VARS += \
        ac_cv_have_decl_OpenSSL_add_all_algorithms=yes
 
 define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tinc $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tincd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
index 351accfd690368df4dc9a97e72b368765ee82df8..640071f116550ea74fe441dd954e79898efcd28f 100644 (file)
@@ -10,8 +10,12 @@ START=42
 SERVICE_USE_PID=1
 
 BIN=/usr/sbin/tincd
-extra_command "up" "<instance> Setting instance up"
-extra_command "down" "<instance> Setting instance down"
+if ( type extra_command >/dev/null 2>&1 ); then
+        extra_command "up" "<instance> Setting instance up"
+        extra_command "down" "<instance> Setting instance down"
+else
+       EXTRA_COMMANDS="up down"
+fi
 
 LIST_SEP="
 "
@@ -142,20 +146,62 @@ prepare_net() {
 
        # append flags
        append_conf_bools "$s" "$TMP_TINC/$s/tinc.conf" \
-               DecrementTTL DirectOnly Hostnames IffOneQueue \
-               LocalDiscovery PriorityInheritance StrictSubnets TunnelServer \
-               ClampMSS IndirectData PMTUDiscovery TCPOnly
+               AutoConnect \
+               DecrementTTL \
+               DeviceStandby \
+               DirectOnly \
+               ExperimentalProtocol \
+               Hostnames \
+               LocalDiscovery \
+               PriorityInheritance \
+               StrictSubnets \
+               TunnelServer \
+               ClampMSS \
+               IndirectData \
+               PMTUDiscovery \
+               TCPOnly
 
        # append params
        append_conf_params "$s" "$TMP_TINC/$s/tinc.conf" \
-               AddressFamily BindToAddress ConnectTo BindToInterface \
-               Broadcast Device DeviceType Forwarding \
-               GraphDumpFile Interface KeyExpire MACExpire \
-               MaxTimeout Mode Name PingInterval PingTimeout \
-               PrivateKey PrivateKeyFile ProcessPriority ReplayWindow \
-               UDPRcvBuf UDPSndBuf \
-               Address Cipher Compression Digest MACLength PMTU \
-               Port PublicKey PublicKeyFile Subnet
+               AddressFamily \
+               BindToAddress \
+               BindToInterface \
+               Broadcast \
+               BroadcastSubnet \
+               ConnectTo \
+               Device \
+               DeviceType \
+               Ed25519PrivateKeyFile \
+               ECDSAPublicKey \
+               Forwarding \
+               Interface \
+               ListenAddress \
+               LocalDiscoveryAddress \
+               Mode \
+               KeyExpire \
+               MACExpire \
+               MaxConnectionBurst \
+               Name \
+               PingInterval \
+               PingTimeout \
+               PrivateKey \
+               PrivateKeyFile \
+               ProcessPriority \
+               Proxy \
+               ReplayWindow \
+               UDPRcvBuf \
+               UDPSndBuf \
+               Address \
+               Cipher \
+               Compression \
+               Digest \
+               MACLength \
+               PMTU \
+               Port \
+               PublicKey \
+               PublicKeyFile \
+               Subnet \
+               Weight
 
        check_gen_own_key "$s" && return 0
 }
@@ -171,7 +217,7 @@ start_instance() {
        append_params "$s" logfile debug
 
        SERVICE_PID_FILE="/var/run/tinc.$s.pid"
-       service_start $BIN -c "$TMP_TINC/$s" -n $s $ARGS --pidfile="$SERVICE_PID_FILE"
+       service_start $BIN -c "$TMP_TINC/$s" $ARGS --pidfile="$SERVICE_PID_FILE"
 }
 
 stop_instance() {