tor-hs: fix rpcd 14528/head
authorJan Pavlinec <jan.pavlinec@nic.cz>
Fri, 15 Jan 2021 11:01:44 +0000 (12:01 +0100)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Fri, 22 Jan 2021 13:10:58 +0000 (14:10 +0100)
Changes:
- add rpcd dependecy
- handle rpcd in post inst/rm sections

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
net/tor-hs/Makefile

index 3a5490a580ad2b60df9dc92fded0cb7e28c1769a..1f10a8193c78e44f2a6cacd1a7a4b5ab6983664c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 02020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+# Copyright (C) 2020-2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tor-hs
 PKG_VERSION:=0.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=GPL-3.0-or-later
@@ -21,7 +21,7 @@ define Package/tor-hs
   CATEGORY:=Network
   SUBMENU:=IP Addresses and Names
   TITLE:=Tor hidden service configurator
-  DEPENDS:=+tor
+  DEPENDS:=+tor +rpcd
 endef
 
 define Package/tor-hs/description
@@ -38,6 +38,18 @@ endef
 define Build/Install
 endef
 
+define Package/tor-hs/postinst
+#!/bin/sh
+[ -z "$${IPKG_INSTROOT}" ] && /etc/init.d/rpcd restart
+exit 0
+endef
+
+define Package/tor-hs/postrm
+#!/bin/sh
+[ -z "$${IPKG_INSTROOT}" ] && /etc/init.d/rpcd restart
+exit 0
+endef
+
 define Package/tor-hs/install
        $(INSTALL_DIR) $(1)/etc/config/
        $(CP) ./files/tor-hs.conf $(1)/etc/config/tor-hs