node: bump to v20.13.1
authorHirokazu MORIKAWA <morikw2@gmail.com>
Tue, 14 May 2024 09:08:46 +0000 (18:08 +0900)
committerRosen Penev <rosenp@gmail.com>
Tue, 14 May 2024 12:01:33 +0000 (05:01 -0700)
Update to v20.13.1

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
lang/node/Makefile
lang/node/patches/003-path.patch
lang/node/patches/202-node_gyp.patch
lang/node/patches/999-localhost-no-addrconfig.patch
lang/node/patches/999-revert_enable_pointer_authentication_on_arm64.patch

index 2f091a62fa99a4486469a2dd3c5e1f07584643ad..1ff311bab8e773ef8c48e664c8302e74b61ebfde 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=node
-PKG_VERSION:=v20.12.2
+PKG_VERSION:=v20.13.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=bc57ee721a12cc8be55bb90b4a9a2f598aed5581d5199ec3bd171a4781bfecda
+PKG_HASH:=a85ee53aa0a5c2f5ca94fa414cdbceb91eb7d18a77fc498358512c14cc6c6991
 
 PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
 PKG_LICENSE:=MIT
index 02b45b6d65447e36ed351741e6448e7a8d02132c..e36bcf10b20e69dfea3c86bd89194125c220d9e3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/internal/modules/cjs/loader.js
 +++ b/lib/internal/modules/cjs/loader.js
-@@ -1529,7 +1529,8 @@ Module._initPaths = function() {
+@@ -1518,7 +1518,8 @@ Module._initPaths = function() {
      path.resolve(process.execPath, '..') :
      path.resolve(process.execPath, '..', '..');
  
index 2105ffcfccd58041b6aa6d7cb74873831d3004d1..a2e47ec883f9b33bae886c27ffe81aee89c97d38 100644 (file)
@@ -1,6 +1,6 @@
 --- a/node.gyp
 +++ b/node.gyp
-@@ -1197,6 +1197,7 @@
+@@ -1214,6 +1214,7 @@
        'dependencies': [
          'deps/simdutf/simdutf.gyp:simdutf#host',
        ],
index 3b24ce12f50b2fb350e2287b37e1e264b4273e8b..870890039bdfe0d29e83c2166a093625d8a12f72 100644 (file)
@@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
  //
  // Permission is hereby granted, free of charge, to any person obtaining a
  // copy of this software and associated documentation files (the
-@@ -1337,13 +1338,6 @@ function lookupAndConnect(self, options)
+@@ -1338,13 +1339,6 @@ function lookupAndConnect(self, options)
      hints: options.hints || 0,
    };
  
index bf8549c1d7d80146ddb106954e02fe44568e4269..b4f855546d2f6f630443317ae59280e23ca74082 100644 (file)
@@ -1,10 +1,10 @@
---- a/configure.py
-+++ b/configure.py
-@@ -1282,7 +1282,6 @@ def configure_node(o):
-   # Enable branch protection for arm64
-   if target_arch == 'arm64':
--    o['cflags']+=['-msign-return-address=all']
-     o['variables']['arm_fpu'] = options.arm_fpu or 'neon'
-   if options.node_snapshot_main is not None:
+--- a/node.gyp
++++ b/node.gyp
+@@ -1215,6 +1215,7 @@
+         'deps/simdutf/simdutf.gyp:simdutf#host',
+       ],
+       'libraries!':[ '-licui18n', '-licuuc', '-licudata', '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
++      'cflags!': ['-mbranch-protection=standard'],
+       'include_dirs': [
+         'tools',
+         'src',