simple-adblock: bugfix: add dnsmasq.nftset to uci_load_validate 20076/head
authorStan Grishin <stangri@melmac.ca>
Mon, 12 Dec 2022 21:43:00 +0000 (21:43 +0000)
committerStan Grishin <stangri@melmac.ca>
Mon, 12 Dec 2022 21:43:09 +0000 (21:43 +0000)
* fixes https://github.com/openwrt/openwrt/issues/11481 thanks to:
* https://github.com/mistepien for reporting
* https://github.com/dave14305 for diagnosing

Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/simple-adblock/Makefile
net/simple-adblock/files/simple-adblock.init

index ac2854e95beac7b3299154af18cca5acd7551755..725ec66b8fef5535ed2fa02e18e4d4451342ee66 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=simple-adblock
 PKG_VERSION:=1.9.3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
 PKG_LICENSE:=GPL-3.0-or-later
 
index cdd2dac36af32654caa653fb56f1f699e57f093a..e57a03b45b22d4c72aa379cc894212c02f6fa31a 100644 (file)
@@ -1510,7 +1510,7 @@ load_validate_config() {
                'verbosity:range(0,2):2' \
                'procd_trigger_wan6:bool:0' \
                'led:or("", "none", file, device, string)' \
-               'dns:or("dnsmasq.addnhosts", "dnsmasq.conf", "dnsmasq.ipset", "dnsmasq.servers", "unbound.adb_list"):dnsmasq.servers' \
+               'dns:or("dnsmasq.addnhosts", "dnsmasq.conf", "dnsmasq.ipset", "dnsmasq.nftset", "dnsmasq.servers", "unbound.adb_list"):dnsmasq.servers' \
                'dns_instance:or(list(integer, string)):0' \
                'allowed_domain:list(string)' \
                'allowed_domains_url:list(string)' \