treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
[feed/packages.git] / ipv6 / miredo / Makefile
index 9e1390a233a99ab87327f2d471645b96f630524c..8527db824db4385801f6bc683030023844b8c2e5 100644 (file)
@@ -14,6 +14,7 @@ PKG_CONFIG_DEPENDS:= \
 PKG_BUILD_PARALLEL:=1
 PKG_CHECK_FORMAT_SECURITY:=0
 PKG_INSTALL:=1
+PKG_BUILD_FLAGS:=gc-sections
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=GPL-2.0-or-later
@@ -52,11 +53,7 @@ CONFIGURE_VARS += \
        ac_cv_header_sys_capability_h=no
 
 TARGET_CFLAGS+= \
-       $(FPIC) \
-       -ffunction-sections \
-       -fdata-sections
-
-TARGET_LDFLAGS += -Wl,--gc-sections
+       $(FPIC)
 
 define Package/miredo/install
        $(INSTALL_DIR) $(1)/usr/lib