treewide: refactor to use PKG_BUILD_FLAGS:=gc-sections
[feed/packages.git] / utils / bluez / Makefile
index c585593cc7b290030769490f895ecda81e7a2b8e..bee4e79a991e6dad543829387e51cf14d07e7aac 100644 (file)
@@ -22,6 +22,7 @@ PKG_CPE_ID:=cpe:/a:bluez:bluez
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
+PKG_BUILD_FLAGS:=gc-sections
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
@@ -79,8 +80,7 @@ define Package/bluez-daemon/conffiles
 /etc/config/bluetooth
 endef
 
-TARGET_CFLAGS += -D_GNU_SOURCE -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -D_GNU_SOURCE
 
 CONFIGURE_ARGS += \
        --enable-static \