mcproxy: update to latest version, add UCI support
[feed/routing.git] / mcproxy / Makefile
index ef0b09e3e643f08685a997fcffcdfb6b66bbc130..cb3fb2080b8dae04db143f5b78d094d737a142d7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mcproxy
-PKG_SOURCE_VERSION:=6638aa9aabd2ccdde8915b61a8e0fb995b1f91a3
-PKG_VERSION:=2014-05-31-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=b7bd2d0809a0d1f177181c361b9a6c83e193b79a
+PKG_VERSION:=2014-12-31-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
@@ -40,11 +40,15 @@ endef
 
 define Package/mcproxy/conffiles
 /etc/mcproxy.conf
+/etc/config/mcproxy
 endef
 
 define Package/mcproxy/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/mcproxy.conf $(1)/etc/mcproxy.conf
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/mcproxy.config $(1)/etc/config/mcproxy
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_CONF) ./files/mcproxy.conf $(1)/etc
        $(INSTALL_BIN) ./files/mcproxy.init $(1)/etc/init.d/mcproxy
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mcproxy-bin $(1)/usr/sbin/mcproxy