nodogsplash2: init script cleanup and refactoring
[feed/routing.git] / nodogsplash2 / Makefile
index 56ffb8a6455930df6a8bd9a4cfb4e5a2e899ff7a..a306316434f947f57907fa66e7cae7516f4fcf19 100644 (file)
@@ -38,15 +38,12 @@ define Package/nodogsplash2/description
 endef
 
 define Package/nodogsplash2/install
+       $(CP) ./files/* $(1)/
+
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/nodogsplash
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) files/nodogsplash.config $(1)/etc/config/nodogsplash
-
        $(INSTALL_DIR) $(1)/etc/nodogsplash/htdocs/images
        $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/nodogsplash/htdocs/
        $(CP) $(PKG_BUILD_DIR)/resources/infoskel.html $(1)/etc/nodogsplash/htdocs/