build: use config.site generated by autoconf-lean, drop hardcoded sitefiles
[openwrt/openwrt.git] / Makefile
index 5301883061589de7c4a7ffbb5e4a8d4c0588f6c6..3c0f927d9d6ee080d027e3cad0a38862417cac0b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -79,12 +79,6 @@ endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
-       @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
-               echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
-               echo '       The missing file will cause configure scripts to fail during compilation.'; \
-               echo '       Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
-               exit 1; \
-       fi
 
 checksum: FORCE
        $(call sha256sums,$(BIN_DIR),$(CONFIG_BUILDBOT))