build: implement make check and make package/X/check
[openwrt/openwrt.git] / Makefile
index 59320d4a207bfe1611241224d2d3189623eab532..51ed5a1132e358c2fade97b93f1ab38c1608e9de 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -44,6 +44,7 @@ $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUI
 $(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
 $(package/stamp-install): $(package/stamp-compile)
 $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check)
 
 printdb:
        @true