add initial version of our new documentation - not too pretty yet, but will be improved
[openwrt/openwrt.git] / docs / Makefile
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644 (file)
index 0000000..0a41287
--- /dev/null
@@ -0,0 +1,15 @@
+openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex
+       $(MAKE) cleanup
+       pdflatex openwrt.tex
+       pdflatex openwrt.tex
+       $(MAKE) cleanup
+       
+clean: cleanup
+       rm -f openwrt.pdf
+
+cleanup: FORCE
+       rm -f *.log *.aux *.toc
+
+
+FORCE:
+.PHONY: FORCE