autotools.mk: autoreconf: fix missing install-sh
[openwrt/openwrt.git] / include / autotools.mk
index aa044aa0b4e516e85e5c65ab2e5372b96b010573..ae320fbde0f90d2b4885c12ae832e92298af99df 100644 (file)
@@ -39,7 +39,9 @@ define autoreconf
                                [ -e $(p)/config.rpath ] || \
                                                ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath; \
                                touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
-                               $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               $(AM_TOOL_PATHS) \
+                                       LIBTOOLIZE='$(STAGING_DIR_HOST)/bin/libtoolize --install' \
+                                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                        $(if $(word 2,$(3)),--no-recursive) \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
                                        $(patsubst %,-I %,$(5)) \