build: fix getting ABI version for binary packages from the same source package
[openwrt/openwrt.git] / include / feeds.mk
index 5676cc4a8f6b3f43d054f5e3d9aa06f036c645ed..98e315bceb5eab214638acdfeca3a309c0a295bb 100644 (file)
@@ -43,5 +43,5 @@ endef
 
 # 1: package name
 define GetABISuffix
-$(if $(filter-out kmod-%,$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v))))
+$(if $(filter-out kmod-%,$(1)),$(if $(ABIV_$(1)),$(ABIV_$(1)),$(foreach v,$(wildcard $(STAGING_DIR)/pkginfo/$(1).version),$(shell cat $(v)))))
 endef