image: fix device profile specific COMPILE targets
[openwrt/openwrt.git] / include / image.mk
index e9dc53f82ead22adf11425de2c016b1a8a4ea88d..5d9d4acb414dfa35b669c47f9f9194c418379961 100644 (file)
@@ -520,6 +520,7 @@ define Device/Build/compile
   $$(_COMPILE_TARGET): $(KDIR)/$(1)
   $(eval $(call Device/Export,$(KDIR)/$(1)))
   $(KDIR)/$(1): FORCE
+       rm -f $(KDIR)/$(1)
        $$(call concat_cmd,$(COMPILE/$(1)))
 
 endef