build: label kernel and rootfs ext4 volumes
[openwrt/openwrt.git] / include / image.mk
index 3e6c9adc661e85b39b437f82a3900bbe6f4268ef..940ae812ea950c8ddbc16a0532b5a903d532473c 100644 (file)
@@ -287,7 +287,7 @@ define Image/mkfs/ubifs
 endef
 
 define Image/mkfs/ext4
-       $(STAGING_DIR_HOST)/bin/make_ext4fs \
+       $(STAGING_DIR_HOST)/bin/make_ext4fs -L rootfs \
                -l $(ROOTFS_PARTSIZE) -b $(CONFIG_TARGET_EXT4_BLOCKSIZE) \
                $(if $(CONFIG_TARGET_EXT4_RESERVED_PCT),-m $(CONFIG_TARGET_EXT4_RESERVED_PCT)) \
                $(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \