build: add support for passing C preprocessor flags for DTS builds
[openwrt/openwrt.git] / include / image.mk
index 275a0adcac9e7581153791c876a565d535450b7a..e5b52d0e97c6c7b6794c538e6944d7417fcb6cf3 100644 (file)
@@ -184,6 +184,7 @@ endef
 # $(4) extra DTC flags
 define Image/BuildDTB
        $(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
+               $(DTS_CPPFLAGS) \
                -I$(DTS_DIR) \
                -I$(DTS_DIR)/include \
                -I$(LINUX_DIR)/include/ \