build: build kernel image before building modules/packages
[openwrt/openwrt.git] / include / kernel-defaults.mk
index e5a0ba367bffd5a09556a039d6c81940bed9dcd8..b069c1e67119323e176fde58fbbf99e275af2d70 100644 (file)
@@ -113,7 +113,7 @@ endef
 
 define Kernel/CompileModules/Default
        rm -f $(LINUX_DIR)/vmlinux $(LINUX_DIR)/System.map
-       +$(KERNEL_MAKE) modules
+       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
 endef
 
 OBJCOPY_STRIP = -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id
@@ -137,7 +137,7 @@ endef
 
 define Kernel/CompileImage/Default
        rm -f $(TARGET_DIR)/init
-       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
+       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all)
        $(call Kernel/CopyImage)
 endef
 
@@ -147,7 +147,7 @@ define Kernel/CompileImage/Initramfs
        $(CP) $(GENERIC_PLATFORM_DIR)/other-files/init $(TARGET_DIR)/init
        $(if $(SOURCE_DATE_EPOCH),touch -hcd "@$(SOURCE_DATE_EPOCH)" $(TARGET_DIR)/init)
        rm -rf $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)/usr/initramfs_data.cpio*
-       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all) modules
+       +$(KERNEL_MAKE) $(if $(KERNELNAME),$(KERNELNAME),all)
        $(call Kernel/CopyImage,-initramfs)
 endef
 else