build: skip kernel stack validation when building on macOS
[openwrt/openwrt.git] / include / kernel.mk
index 8dfe903bccbb6857d36feda25bf90f80e346acf1..975cf455c4f3aefaa7e103496d4a460194215a5e 100644 (file)
@@ -129,6 +129,10 @@ ifdef CONFIG_USE_SPARSE
   KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
 endif
 
+ifeq ($(HOST_OS),Darwin)
+  export SKIP_STACK_VALIDATION:=1
+endif
+
 PKG_EXTMOD_SUBDIRS ?= .
 
 define populate_module_symvers