kernel: fix module packages postinst by pointing to the new functions.sh location
[openwrt/openwrt.git] / include / kernel.mk
index 6185237765472355349e4b1b0a7bf5163cff6dca..8df70ba5f683795016e154dfca281bfc9e507ea2 100644 (file)
@@ -104,7 +104,7 @@ define ModuleAutoLoad
                mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
                echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
-               echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
+               echo ". /lib/functions.sh" >> $(2)/CONTROL/postinst; \
                echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
                chmod 0755 $(2)/CONTROL/postinst; \
        fi