we only support v3.x kernels
[openwrt/openwrt.git] / include / kernel.mk
index c0d8ef8a2368f5a91226545943799429e6b85feb..c84f7bd37f90c06b8758134fb55f1b21c0e92e8c 100644 (file)
@@ -52,11 +52,7 @@ else
   LINUX_SOURCE:=linux-$(LINUX_VERSION).tar.bz2
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   ifeq ($(call qstrip,$(CONFIG_EXTERNAL_KERNEL_TREE))$(call qstrip,$(CONFIG_KERNEL_GIT_CLONE_URI)),)
-    ifeq ($(word 1,$(subst ., ,$(KERNEL_BASE))),3)
       LINUX_SITE:=@KERNEL/linux/kernel/v3.x$(TESTING)
-    else
-      LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING)
-    endif
   endif
 
   ifneq ($(TARGET_BUILD),1)