package-defaults.mk: set DISABLE_NLS only if not CONFIG_BUILD_NLS
[openwrt/openwrt.git] / include / package-defaults.mk
index 9567e04a7a0ca612ce83e0be8924f1ceb979f97b..e37ab88a310da6ef4dee35164b56d57d495c3bae 100644 (file)
@@ -67,7 +67,11 @@ ifneq ($(strip $(PKG_UNPACK)),)
 endif
 
 EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
-DISABLE_NLS:=--disable-nls
+ifeq ($(CONFIG_BUILD_NLS),y)
+    DISABLE_NLS:=
+else
+    DISABLE_NLS:=--disable-nls
+endif
 
 CONFIGURE_PREFIX:=/usr
 CONFIGURE_ARGS = \