build: remove package preconfig feature
[openwrt/openwrt.git] / include / package-dumpinfo.mk
index 1be7d958d424616ab13e23dfbaa8058cb20e682b..7cc8f3f6dc5d8e3fcfa2b7042cf46f6130296c04 100644 (file)
@@ -9,19 +9,6 @@ ifneq ($(DUMP),)
 
 dumpinfo: FORCE
 
-define Config/template
-Preconfig: $(1)
-Preconfig-Type: $(2)
-Preconfig-Default: $(3)
-Preconfig-Label: $(4)
-
-endef
-
-define Config
-  Preconfig/$(1) = $$(call Config/template,$(1),$(2),$(3),$(4))
-  preconfig_$$(1) += $(1)
-endef
-
 define Dumpinfo/Package
 $(info Package: $(1)
 $(if $(MENU),Menu: $(MENU)
@@ -59,8 +46,7 @@ $(if $(URL),$(URL)
 $(if $(Package/$(1)/config),Config:
 $(Package/$(1)/config)
 @@
-)$(foreach pc,$(preconfig_$(1)),
-$(Preconfig/$(pc))))
+))
 endef
 
 define Feature/Default