build: clean up redundant touching of the package install info file
[openwrt/openwrt.git] / include / package.mk
index a3ef3029d80b79af6d8a8481f3b4374effcf0d27..bf308bb5c076aa8f01eeb8638bdd60103abb273a 100644 (file)
@@ -293,13 +293,13 @@ Build/DistCheck=$(call Build/DistCheck/Default,)
 .PHONY: prepare-package-install
 prepare-package-install:
        @mkdir -p $(PKG_INFO_DIR)
-       @touch $(PKG_INSTALL_STAMP).clean
+       @rm -f $(PKG_INSTALL_STAMP)
        @echo "$(filter-out essential nonshared,$(PKG_FLAGS))" > $(PKG_INSTALL_STAMP).flags
 
 $(PACKAGE_DIR):
        mkdir -p $@
 
-compile: prepare-package-install
+compile:
 .install: .compile
 install: compile