build: add which command to build requirements
[openwrt/openwrt.git] / include / prereq-build.mk
index bbeba3f8ff6a8c91ae353326fc161c729aa7aa42..32edc6e4370aa4197c1df0cb76f867a104469534 100644 (file)
@@ -166,6 +166,9 @@ $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
 $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
        rsync --version </dev/null))
 
+$(eval $(call SetupHostCommand,which,Please install 'which', \
+       which which | grep which))
+
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)
        $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<