include/prereq-build.mk: macOS cross build improvements
[openwrt/openwrt.git] / include / prereq-build.mk
index 4a8c2b063a8a4c64df52a642ae689afbcc668f2d..80d549af39ba8002a7a2be25e03fcca39fdaa1a8 100644 (file)
@@ -130,7 +130,12 @@ $(eval $(call SetupHostCommand,getopt, \
        Please install an extended getopt version that supports --long, \
        gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
        getopt -o t --long test -- --test | grep '^ *--test *--', \
-       /usr/local/opt/gnu-getopt/bin/getopt -o t --long test -- --test | grep '^ *--test *--'))
+       /usr/local/opt/gnu-getopt/bin/getopt -o t --long test -- --test | grep '^ *--test *--', \
+       /opt/local/bin/getopt -o t --long test -- --test | grep '^ *--test *--'))
+
+$(eval $(call SetupHostCommand,realpath,Please install a 'realpath' utility, \
+       grealpath /, \
+       realpath /))
 
 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
        gnustat -c%s $(TOPDIR)/Makefile, \