prereq-build: limit argp/fts/obstack/libintl.h to Linux OS
[openwrt/openwrt.git] / include / prereq-build.mk
index 7b345ebbaa41a70b7d260866a9a09f0192700013..8fae92ab977087f38f9bac051d57e49c8bc1163b 100644 (file)
@@ -204,17 +204,19 @@ $(eval $(call SetupHostCommand,which,Please install 'which', \
        /bin/which which, \
        which which))
 
-$(eval $(call RequireCHeader,argp.h, \
+ifeq ($(HOST_OS),Linux)
+  $(eval $(call RequireCHeader,argp.h, \
        Missing argp.h Please install the argp-standalone package if musl libc))
 
-$(eval $(call RequireCHeader,fts.h, \
+  $(eval $(call RequireCHeader,fts.h, \
        Missing fts.h Please install the musl-fts-dev package if musl libc))
 
-$(eval $(call RequireCHeader,obstack.h, \
+  $(eval $(call RequireCHeader,obstack.h, \
        Missing obstack.h Please install the musl-obstack-dev package if musl libc))
 
-$(eval $(call RequireCHeader,libintl.h, \
+  $(eval $(call RequireCHeader,libintl.h, \
        Missing libintl.h Please install the musl-libintl package if musl libc))
+endif
 
 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
        mkdir -p $(dir $@)