prereq-build: require python3-distutils
[openwrt/openwrt.git] / include / prereq-build.mk
index 8adf0d03dd4f4637ceaa9d299c487908063b69d0..922e7c544bbf85b769836345e1d2991d4ab8ac27 100644 (file)
@@ -31,7 +31,7 @@ $(eval $(call SetupHostCommand,gcc, \
        gcc --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-gcc, \
-       \nPlease reinstall the GNU C Compiler (6 or later) - \
+       Please reinstall the GNU C Compiler (6 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -))
@@ -43,7 +43,7 @@ $(eval $(call SetupHostCommand,g++, \
        g++ --version | grep -E 'Apple.(LLVM|clang)' ))
 
 $(eval $(call TestHostCommand,working-g++, \
-       \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
+       Please reinstall the GNU C++ Compiler (6 or later) - \
        it appears to be broken, \
        echo 'int main(int argc, char **argv) { return 0; }' | \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
@@ -102,9 +102,9 @@ $(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
        gpatch --version 2>&1 | grep 'Free Software Foundation', \
        patch --version 2>&1 | grep 'Free Software Foundation'))
 
-$(eval $(call SetupHostCommand,diff,Please install diffutils, \
-       gdiff --version 2>&1 | grep diff, \
-       diff --version 2>&1 | grep diff))
+$(eval $(call SetupHostCommand,diff,Please install GNU diffutils, \
+       gdiff --version 2>&1 | grep GNU, \
+       diff --version 2>&1 | grep GNU))
 
 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
        gcp --help 2>&1 | grep 'Copy SOURCE', \
@@ -170,6 +170,10 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
        python3.6 -V 2>&1 | grep 'Python 3', \
        python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
 
+$(eval $(call TestHostCommand,python3-distutils, \
+       Please install the Python3 distutils module, \
+       $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
+
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))