some minor fixes, cleanups, package build abstraction
[openwrt/openwrt.git] / include / target.mk
index c8eb76c254c03089e59347a0aa4e7f849caecc5f..1590b9109190027dd3a5e395f6407db83b83a677 100644 (file)
@@ -75,9 +75,11 @@ define Profile
   endif
 endef
 
--include $(PLATFORM_DIR)/profiles/*.mk
-ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
-  -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
+  -include $(PLATFORM_DIR)/profiles/*.mk
+  ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+    -include $(PLATFORM_SUBDIR)/profiles/*.mk
+  endif
 endif
 
 $(eval $(call shexport,Target/Description))