build: add nconfig
[openwrt/openwrt.git] / include / toplevel.mk
index 5cf93ce7effd76f6da3cb3cf43ef8f842d975d5a..ba5959576424f384e3aa0e6de6a559fd84d46a9a 100644 (file)
@@ -141,6 +141,13 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
        [ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; \
                $< Config.in
 
+nconfig: scripts/config/nconf prepare-tmpinfo FORCE
+       if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+               cp $(HOME)/.openwrt/defconfig .config; \
+       fi
+       [ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; \
+               $< Config.in
+
 xconfig: scripts/config/qconf prepare-tmpinfo FORCE
        if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
                cp $(HOME)/.openwrt/defconfig .config; \